Thursday 22nd April 2021

WCCIS WCCIS - Performance Degradation

We are currently receiving reports of poor performance and slowness from our WCCIS customers. Please be aware that we are currently investigation and will provide another update shortly.

UPDATE 15:54: We are no longer seeing any performance or slowness on our hosted platform but we are still monitoring the situation. If any of our customers are still experiencing poor performance please contact the Advanced Service Desk.

UPDATE 16:07: We would like to inform that we are no longer receiving reports and we have had confirmation that our customers have returned to businesses as usual.

Please contact us via our Support Portal.