Sunday 11th April 2021

WCCIS WCCIS Performance issues

We are aware that currently CCIS users are experiencing performance problems with using or viewing documents, workflows and general application slowness at the moment. Please be assured that we are currently looking into this and will provide a further update in due course.

UPDATE: 21:08 - Please be aware that our teams are working on a solution at the moment and we will provide another update in due course.

UPDATE:23:44 - Please be aware that our teams have managed to resolve a number of the problems users were experiencing today and are currently working towards finalising their resolutions. We apologize for any inconvenience caused.

UPDATE:00:10 - Please be aware that our teams have managed to resolve a number of the problems users were experiencing today. We are currently still trying to resolve an issue with Workflows and ask that users within your teams be made aware that they and take any actions required until this is resolved.

Please contact us via our Support Portal.