Friday 31st July 2020

Adastra 111 Reduced Performance For Adastra 111 customers

We are aware of slowness affecting some hosted Adastra customers. This is being investigated as a high priority incident.

Update 22:18: Performance degradation has improved since users raised concerns but we are still investigating reports of slowness.

Update 22:46: We are still investigating the reduced performance and will provide another update in due course.

Update 23:17: Resolved. Advanced users should now have seen their performance return to expected levels and no further problems are expected.

Please contact us via our Support Portal.