Monday 11th March 2024

Odyssey HSSI - 23577727

AHC Ref: 23577727

Status: Investigating

Details: Advanced have had multiple reports from customer that they are unable to access Odyssey. The issue is under investigation as a priority and further updates will follow.

Update 23:20 - The relevant technical teams have been engaged and the issue is under investigation from cross-functional stakeholders.

Update 00:00 - Remedial work has been undertaken that has restored functionality to normal and testing has indicated the issue is resolved.

We apologise for the inconvenience caused.

Please can this message be passed on to any of your staff who may be operational at this time.

If you require any further information please do not hesitate to contact the Service Desk.

Please contact us via our Support Portal.