Monday 7th March 2022

WCCIS WCCIS - Application Inaccessibility

Please be aware that there are some customers currently experiencing problems when trying to connect to CareDirector. We are currently investigating.

[Update 12:50]: Internal investigations and checks have found no fault however there has been a report of network connectivity issues within BT's PSBA.

[Update 14:06]: Reports have indicated that the network issues experienced earlier today are no longer occurring.

Please contact us via our Support Portal.