Thursday 13th May 2021

WCCIS WCCIS Performance Issues

Advanced has received alerts that there are currently two sites experiencing poor performance . Our teams are investigating.

[UPDATE 13:48]: We would ask that if any of our users are experiencing slowness or poor performance within the CareDirector application that you please raise a support Incident with Advanced.

[UPDATE 14:48]: Please be aware our teams are still investigating.

Please contact us via our Support Portal.