Wednesday 5th May 2021

WCCIS - Performance Issues

Please be aware we have received an alert to potential performance issues. If our users are experiencing slowness within the CareDirector application please contact the Advanced Service Desk. Our teams are engaged and investigating currently.

[UPDATE 11:00] We are still currently investigating. We apologize for the inconvenience this is causing users.

[UPDATE 13:45] We are still currently investigating. We apologize for the inconvenience this is causing users.

[UPDATE 16:58] We are no longer receiving reports or alerts however we will continue to investigate and will continue to monitor performance.

Please contact us via our Support Portal.