Sunday 2nd May 2021

Staffplan Citrix Connection / Login

Advanced is aware that we are currently receiving reports of our Staffplan users not being able to login in via their Citrix logins to the Staffplan application. Please be aware that we are currently investigating.

[UPDATE 11:02]: We have identified the cause to the problems and our teams are moving to resolve the issue.

[UPDATE 11:25]: We have received reports of iConnect also being affected. Please be advised.

[UPDATE 12:50]: We believe the issues reported by our customers have been resolved. We will continue to monitor the situation in the interim.

Please contact us via our Support Portal.