Sunday 2nd May 2021

Aremote Web Service Relay Adastra - Aremote

We are currently receiving reports that our Toughbook users are unable to launch Aremote and are receiving an error message stating "Unable to connect to WSR web services". Please be advised that teams are currently investigating.

[UPDATE 11:02]: We have identified the cause to the problems and our teams are moving to resolve the issue.

[UPDATE 12:50]: We believe the issues reported by our customers have been resolved. We will continue to monitor the situation in the interim.

Please contact us via our Support Portal.